MX Connect latency

Incident Report for MX Connect

Resolved

This incident has been resolved.
Posted May 27, 2025 - 15:41 EDT

Update

A fix has been implemented and we are monitoring the issues
Posted May 27, 2025 - 15:24 EDT

Monitoring

A fix has been implemented and we are monitoring the issues
Posted May 27, 2025 - 13:19 EDT

Investigating

We are investigating reports of latency with MX Connect (www.mxconnect.com). We are actively researching and will provide more information shortly.
Posted May 27, 2025 - 12:03 EDT
This incident affected: MX Connect.